add some media-sound packages

pull/1/head
Alexander Miroshnichenko 2020-05-10 13:52:30 +03:00
parent b2d5f88926
commit 236b78d73f
Signed by: alex
GPG Key ID: E93720C6C73A77F4
14 changed files with 561 additions and 0 deletions

View File

@ -0,0 +1,2 @@
DIST cozy-0.6.16.tar.gz 649482 BLAKE2B 8bf41ac3ae19337d70aa745b8ec8d619954effcfe1c0e52f0933fba6df366aa8e5fd14ea12a38996b06e944291836e4ac6634a30c560aacf41cf9b92df1ab5ce SHA512 4f4f9b84b3b6bda2fdb59cd298912c49d44c2c28babf4b47dda4574dbc5eaa5bdb452b31fe8ee3dd9b67dd1adce879b04adb5addf9566c73f22f4ca826e5aa2b
EBUILD cozy-0.6.16.ebuild 1110 BLAKE2B 672041d60e697a34ab2451cf1edebef7502a51b95b0d7be5e18c04d7b52107baccd5fcc8dc7068d704dc0cc237d530a6971c6268de937e813cafbcbe964aecc6 SHA512 987d34e50276a05d3d1d88e258c37a3c93a8989bc1cf2ba8aca207864f36865ed723f2fa74bdec4b26fed78a9045ecd3b562c1372e6e2af5305e2af9b1695765

View File

@ -0,0 +1,46 @@
# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7,8} )
inherit distutils-r1 meson
DESCRIPTION="A modern audio book player for Linux and macOS using GTK+ 3"
HOMEPAGE="https://cozy.geigi.de"
SRC_URI="https://github.com/geigi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~x86"
IUSE=""
RDEPEND=">=dev-lang/python-3.0
>=x11-libs/gtk+-3.18:3
>=dev-python/peewee-3.9.6[${PYTHON_USEDEP}]
media-libs/mutagen[${PYTHON_USEDEP}]
dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
sys-apps/file
media-libs/gstreamer:1.0
media-libs/gst-plugins-good:1.0
media-libs/gst-plugins-bad:1.0
media-libs/gst-plugins-ugly:1.0
media-plugins/gst-plugins-libav:1.0
dev-python/gst-python:1.0[${PYTHON_USEDEP}]
dev-python/distro[${PYTHON_USEDEP}]
dev-libs/appstream-glib
dev-util/desktop-file-utils"
DEPEND="${RDEPEND}
>=dev-util/meson-0.4.0
dev-util/ninja
dev-python/setuptools[${PYTHON_USEDEP}]"
src_configure() {
meson_src_configure
}
src_install() {
meson_src_install
}

View File

@ -0,0 +1,3 @@
DIST morituri-0.2.3.tar.bz2 265302 SHA256 20884da088392e8c2e89dda962e78714689ff80b8066fd2301f42be4835e60ac SHA512 35f734c90412765e74ef2a61a0ff30d1a783b5fc3e1c24a8cdf5a29bcde719cf775cf98110bb05a77f1d0e49566825f890db9b2cd7668099303450ef6913d556 WHIRLPOOL f04f673044a128a6f8dd02d1da40d24510c90443f0e67574d379d2323c50fa08e73b49119824ea1c4157647295faebfd9a2af2f3d4bfba522f5d693eb167436f
EBUILD morituri-0.2.3.ebuild 1781 SHA256 b8fabe43d8ef39b602f7e75a707d8eaeb0c7b8d36af653c4ba281cba4128e1d3 SHA512 ee25c923cad7f41cbe3f8ebfab891b18675aff1a8be02d9b17c4b208a233cee3af36fc2aaa15db247a5369b3bf9e974242530961a8ba2737a2d5b85b30eedafe WHIRLPOOL b3c6f7735414a3e16b371d1765303c13f3e491d1783ff97b213a818d550979a832c101363ff8c16f0adf857dc348bb6a7dce262dcfc95365391985b115da16f8
EBUILD morituri-9999.ebuild 1500 SHA256 6b65a4b1b607bb3e5eb18bced1bf3912722cdfa5b1372bcab6fa6ed4f7528658 SHA512 397483644e2806af8c48adc53911b3d27e6776a032b929983dc041f0fa866d0c52892aec718615c25cb65543e3918bb3104f67825119cc0116c186ee1d0e8e12 WHIRLPOOL 1d25b7bd9c90d1a3901fdb686bf03b19be96871c3cd5a9747d5881cca391f68f3578e6f4eced06d9fdb5da27e3f67f3edf20602049fca49de8e5e5210f2d609c

View File

@ -0,0 +1,72 @@
# Copyright 1999-2014 Tiziano Mueller
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit bash-completion-r1 python-single-r1
DESCRIPTION="CD ripper aiming for accuracy over speed."
HOMEPAGE="http://thomas.apestaart.org/morituri/trac/wiki"
SRC_URI="http://thomas.apestaart.org/download/morituri/${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="alac +cddb +cdio doc +flac test wav wavpack"
RDEPEND="${PYTHON_DEPS}
media-sound/cdparanoia
app-cdr/cdrdao
media-libs/gstreamer
alac? ( media-plugins/gst-plugins-ffmpeg )
cddb? ( dev-python/cddb-py[${PYTHON_USEDEP}] )
cdio? ( dev-python/pycdio )
flac? ( media-plugins/gst-plugins-flac )
wav? ( media-libs/gst-plugins-good )
wavpack? ( media-plugins/gst-plugins-wavpack )
dev-python/gst-python:0.10[${PYTHON_USEDEP}]
dev-python/pygobject[${PYTHON_USEDEP}]
dev-python/pygtk[${PYTHON_USEDEP}]
dev-python/pyxdg[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
doc? ( dev-python/epydoc[${PYTHON_USEDEP}] )
test? ( dev-python/pychecker[${PYTHON_USEDEP}] )"
src_prepare() {
# replace by fixed path to have it properly set by python_doscript
sed -i \
-e 's|@PYTHON@|/usr/bin/python|' \
bin/rip.in || die
# checks for .git and makes the install fail if not found
rm morituri/configure/uninstalled.py
}
src_configure() {
# disable doc building, we do it manually
export ac_cv_prog_EPYDOC=""
# disable automatic tests
export ac_cv_prog_PYCHECKER=""
default
}
src_compile() {
default
if use doc ; then
cd doc
epydoc -o reference ../morituri || die "generating docs failed"
fi
}
src_install() {
default
python_doscript bin/rip
rm -rf "${D}/etc"
dobashcomp etc/bash_completion.d/rip
use doc && dohtml -r doc/reference/*
}

View File

@ -0,0 +1,68 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit bash-completion-r1 python-single-r1 eutils autotools git-2
DESCRIPTION="A CD ripper aiming for accuracy over speed."
HOMEPAGE="http://thomas.apestaart.org/morituri/trac/"
EGIT_REPO_URI="git://github.com/thomasvs/morituri.git"
EGIT_HAS_SUBMODULES=1
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~x86 ~amd64"
IUSE="alac +cdio doc +cddb +flac test wav wavpack"
RDEPEND="media-sound/cdparanoia
media-plugins/gst-plugins-cdparanoia
app-cdr/cdrdao
media-libs/gstreamer
>=media-libs/gst-plugins-base-0.10.22
alac? ( media-plugins/gst-plugins-ffmpeg )
cdio? ( dev-python/pycdio )
cddb? ( dev-python/cddb-py )
flac? ( media-plugins/gst-plugins-flac )
wav? ( media-libs/gst-plugins-good )
wavpack? ( media-plugins/gst-plugins-wavpack )
doc? ( dev-python/epydoc )
test? ( dev-python/pychecker )
dev-python/gst-python:0.10
dev-python/python-musicbrainz
dev-python/python-musicbrainz-ngs
dev-python/pygobject
dev-python/pygtk
dev-python/pyxdg"
DEPEND="${RDEPEND}"
src_prepare() {
eautoreconf
}
src_configure() {
# disable doc building
local ac_cv_prog_EPYDOC=""
# disable test
local ac_cv_prog_PYCHECKER=""
default
}
src_install() {
default
python_doscript bin/rip
rm -rf "${D}/etc" || die
dobashcomp etc/bash_completion.d/rip
dodoc AUTHORS HACKING NEWS README RELEASE TODO
use doc && dohtml -r doc/reference/*
}

View File

@ -0,0 +1,3 @@
AUX pulseaudio-11.1-disable-flat-volumes.patch 1992 BLAKE2B 1ffbaf129d57abc7c02f430bdd59a76384456d7ef020e9765bc0541327279dcf7d005d87fe989fd0c89b2767564f99af87ece8c374e1d67c5d1cae1695f0819c SHA512 603f60ef38aeba83038fe5dc9e5f6a82e42d10a7f057f158b489dd04857c3bc8203b728d9df6736314ee3002648390cd564fdce347f2e6791e901a47041dd1fc
DIST pulseaudio-13.0.tar.xz 1901768 BLAKE2B 651a80f54525f196bcb036d893fedd4d9f34e10459918281397a45f498c31bff0d0c836f4e64aab5ac2612ffd5a0cab1a41ea710bbee5fd34dfc9ea1236deea9 SHA512 d445b8ccd43029a0ca0e456fc9291a79d3434d6496ead7eb329ab348d5249235e8bde6cf2be68765d8f761452dbe1486fb10c739e40b1e67ed75787bbd24ac0c
EBUILD pulseaudio-13.0.ebuild 5363 BLAKE2B 948a4b8d20c5b039043759bba33286516c4e2a9eec4f31e996740949fe984fd3f56731ee8f75c4f8904a58859918f12bddb55dea44f221e754592ace54f49a4e SHA512 6ef9c5468f8f8a9e52cd8ad0214399da4664294ae7e7d98bd69f8a6b6478e53913f0a86bad5c2162971104cba57c4a8315dac8dacf4473bf0cfe2287cbbc69bc

View File

@ -0,0 +1,48 @@
diff -up a/man/pulse-daemon.conf.5.xml.in b/man/pulse-daemon.conf.5.xml.in
--- a/man/pulse-daemon.conf.5.xml.in 2016-05-26 23:21:17.000000000 -0500
+++ b/man/pulse-daemon.conf.5.xml.in 2016-05-31 10:01:55.679976730 -0500
@@ -220,7 +220,7 @@ License along with PulseAudio; if not, s
<p><opt>flat-volumes=</opt> Enable 'flat' volumes, i.e. where
possible let the sink volume equal the maximum of the volumes of
the inputs connected to it. Takes a boolean argument, defaults
- to <opt>yes</opt>.</p>
+ to <opt>no</opt>.</p>
</option>
</section>
diff -up a/src/daemon/daemon-conf.c b/src/daemon/daemon-conf.c
--- a/src/daemon/daemon-conf.c 2016-05-26 23:21:17.000000000 -0500
+++ b/src/daemon/daemon-conf.c 2016-05-31 10:01:55.680976735 -0500
@@ -68,7 +68,7 @@ static const pa_daemon_conf default_conf
.realtime_priority = 5, /* Half of JACK's default rtprio */
.disallow_module_loading = false,
.disallow_exit = false,
- .flat_volumes = true,
+ .flat_volumes = false,
.exit_idle_time = 20,
.scache_idle_time = 20,
.script_commands = NULL,
diff -up a/src/daemon/daemon.conf.in b/src/daemon/daemon.conf.in
--- a/src/daemon/daemon.conf.in 2016-05-31 10:01:55.680976735 -0500
+++ b/src/daemon/daemon.conf.in 2016-05-31 10:02:28.048133267 -0500
@@ -57,7 +57,7 @@ ifelse(@HAVE_DBUS@, 1, [dnl
; enable-lfe-remixing = no
; lfe-crossover-freq = 0
-; flat-volumes = yes
+; flat-volumes = no
ifelse(@HAVE_SYS_RESOURCE_H@, 1, [dnl
; rlimit-fsize = -1
diff -up a/src/pulsecore/core.c b/src/pulsecore/core.c
--- a/src/pulsecore/core.c 2016-05-26 23:21:17.000000000 -0500
+++ b/src/pulsecore/core.c 2016-05-31 10:01:55.681976740 -0500
@@ -135,7 +135,7 @@ pa_core* pa_core_new(pa_mainloop_api *m,
c->exit_idle_time = -1;
c->scache_idle_time = 20;
- c->flat_volumes = true;
+ c->flat_volumes = false;
c->disallow_module_loading = false;
c->disallow_exit = false;
c->running_as_daemon = false;

View File

@ -0,0 +1,195 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit autotools bash-completion-r1 flag-o-matic gnome2-utils linux-info systemd user udev multilib-minimal
DESCRIPTION="A networked sound server with an advanced plugin system"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/PulseAudio/"
SRC_URI="https://freedesktop.org/software/pulseaudio/releases/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha amd64 ~arm arm64 ~hppa ~ia64 ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux"
# +alsa-plugin as discussed in bug #519530
IUSE="+caps +glib headers-only ipv6 libressl cpu_flags_arm_neon selinux ssl"
# libpcre needed in some cases, bug #472228
CDEPEND="
|| (
elibc_glibc? ( virtual/libc )
elibc_uclibc? ( virtual/libc )
dev-libs/libpcre
)
>=media-libs/libsndfile-1.0.20[${MULTILIB_USEDEP}]
caps? ( >=sys-libs/libcap-2.22-r2[${MULTILIB_USEDEP}] )
glib? ( >=dev-libs/glib-2.26.0:2[${MULTILIB_USEDEP}] )
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:= )
)
dev-libs/libltdl:0
selinux? ( sec-policy/selinux-pulseaudio )
" # libltdl is a valid RDEPEND, libltdl.so is used for native abi in pulsecore and daemon
RDEPEND="${CDEPEND}
"
DEPEND="${RDEPEND}
sys-devel/m4
dev-libs/libatomic_ops
virtual/pkgconfig
>=sys-devel/gettext-0.19.3
"
PATCHES=(
"${FILESDIR}"/pulseaudio-11.1-disable-flat-volumes.patch # bug 627894
)
pkg_pretend() {
CONFIG_CHECK="~HIGH_RES_TIMERS"
WARNING_HIGH_RES_TIMERS="CONFIG_HIGH_RES_TIMERS:\tis not set (required for enabling timer-based scheduling in pulseaudio)\n"
check_extra_config
if linux_config_exists; then
local snd_hda_prealloc_size=$(linux_chkconfig_string SND_HDA_PREALLOC_SIZE)
if [ -n "${snd_hda_prealloc_size}" ] && [ "${snd_hda_prealloc_size}" -lt 2048 ]; then
ewarn "A preallocated buffer-size of 2048 (kB) or higher is recommended for the HD-audio driver!"
ewarn "CONFIG_SND_HDA_PREALLOC_SIZE=${snd_hda_prealloc_size}"
fi
fi
}
pkg_setup() {
linux-info_pkg_setup
gnome2_environment_reset #543364
enewgroup audio 18 # Just make sure it exists
}
src_prepare() {
default
# Skip test that cannot work with sandbox, bug #501846
sed -i -e '/lock-autospawn-test /d' src/Makefile.am || die
sed -i -e 's/lock-autospawn-test$(EXEEXT) //' src/Makefile.in || die
eautoreconf
}
multilib_src_configure() {
local myconf=(
--disable-adrian-aec
--disable-esound
--disable-gconf
--disable-solaris
--enable-largefile
--localstatedir="${EPREFIX}"/var
--with-systemduserunitdir=$(systemd_get_userunitdir)
--with-udev-rules-dir="${EPREFIX}/$(get_udevdir)"/rules.d
--disable-alsa
--disable-bluez5
--disable-gtk3
--disable-jack
--disable-samplerate
--disable-lirc
--disable-orc
--disable-oss-output
$(multilib_native_use_enable glib gsettings)
$(multilib_native_use_enable ssl openssl)
# tests involve random modules, so just do them for the native
--disable-default-build-tests
--disable-udev
--disable-webrtc-aec
--disable-avahi
--without-fftw
--without-soxr
--with-database=simple
--disable-asyncns
$(use_enable glib glib2)
$(use_enable cpu_flags_arm_neon neon-opt)
--disable-tcpwrap
--disable-dbus
--disable-x11
--disable-systemd-daemon
--disable-systemd-login
--disable-systemd-journal
$(use_enable ipv6)
$(use_with caps)
)
if ! multilib_is_native_abi; then
myconf+=(
# hack around unnecessary checks
# (results don't matter, we're not building anything using it)
ac_cv_lib_ltdl_lt_dladvise_init=yes
LIBSPEEX_CFLAGS=' '
LIBSPEEX_LIBS=' '
)
else
# Make padsp work for non-native ABI, supposedly only possible with glibc; this is used by /usr/bin/padsp that comes from native build, thus we need this argument for native build
if use elibc_glibc ; then
myconf+=( --with-pulsedsp-location="${EPREFIX}"'/usr/\\$$LIB/pulseaudio' )
fi
fi
ECONF_SOURCE=${S} \
econf "${myconf[@]}"
}
multilib_src_compile() {
if multilib_is_native_abi; then
emake
else
local targets=( libpulse.la libpulsedsp.la libpulse-simple.la )
use glib && targets+=( libpulse-mainloop-glib.la )
emake -C src ${targets[*]}
fi
}
multilib_src_test() {
# We avoid running the toplevel check target because that will run
# po/'s tests too, and they are broken. Officially, it should work
# with intltool 0.41, but that doesn't look like a stable release.
if multilib_is_native_abi; then
emake -C src check
fi
}
multilib_src_install() {
if multilib_is_native_abi; then
emake -j1 DESTDIR="${D}" bashcompletiondir="$(get_bashcompdir)" install
else
local targets=( libpulse.la libpulse-simple.la )
use glib && targets+=( libpulse-mainloop-glib.la )
emake DESTDIR="${D}" install-pkgconfigDATA
emake DESTDIR="${D}" -C src \
install-libLTLIBRARIES \
install-padsplibLTLIBRARIES \
lib_LTLIBRARIES="${targets[*]}" \
install-pulseincludeHEADERS
fi
}
multilib_src_install_all() {
dodoc NEWS README todo
# Create the state directory
use prefix || diropts -o pulse -g pulse -m0755
find "${ED}" \( -name '*.a' -o -name '*.la' \) -delete || die
if use headers-only ; then
rm -rf "${D}"/usr/bin "${D}"/usr/lib "${D}"/usr/lib64/{[a-o]*,[q-z]*,pu*} "${D}"/usr/share "${D}"/etc || die
fi
}
pkg_postinst() {
gnome2_schemas_update
}
pkg_postrm() {
gnome2_schemas_update
}

View File

@ -0,0 +1,4 @@
AUX 0.6.2-utf8-configure.patch 842 SHA256 a448030b52b8df4cb407ca391b5f6ce38561dda03b67232d0ad2454812258efc SHA512 a32b731bece5757f9a4140d07a33600d7d66c3eae9fb463e81a2a66961db3950967f553fee90c4ddb39b73ac8ff95b4cfb6f8679ed967dd5581e70518cac04f5 WHIRLPOOL 8abe0fc510ea986eccb2f2615fdf4fd550b00c10ad91c9438924638875a2cc6cafe8030d152ff985194274c642928ab5fc4e8100eba2cc389457660eef801ecc
AUX 0.6.2-utf8-fix.patch 659 SHA256 a054edee04b699f894b8579e349df8d4211b6401b86f760fb35f6ef6b054d55f SHA512 3eb3b0ffc821e9a153ad2395963815c645d372b082707bee4844287527f2636c00b01eb6bd612b43083ab8cbb9eb5158f5ab61cd38ecc478f6d556f2ed41945f WHIRLPOOL 64b72c6fdb4ad7a1effd4b0f792c1db7cd2d1f02d828831d735263566882c1a25a619124bf5453a8c76a78432f8006c8050c25f066eb5d29b46b527ebfd5ca1e
DIST rubyripper-0.6.2.tar.gz 176969 SHA256 5179483142d24467d6a670ccacbc16c55170e083087c9327276ea57946e102d8 SHA512 f5fc05bf59b703990b32010228d9468760ece2a4dae6bc978c9d19d5d75af4a71526903176cbf13a262f96317477a24c673368f09c888d8bed636de96f0d880e WHIRLPOOL ddda3f27a4914f101add6a453e436d45b74906faf625f89a6f4d5b552bafa5facb5e63f4e45a9072390b7e2c9d0030364b484e4ed84935071acf531dfb8733ae
EBUILD rubyripper-0.6.2.ebuild 1176 SHA256 ed4a484a288e9f1abc7fadd0f9d3665f77b55f51b3cb10d329e071a5f2497b41 SHA512 02558ec7fc47c20c37ccf28e53cb66bd3e5822f5eb28888b89a26585bf8989d5dbe4a427f69cab148ed38e6df26d23194ff7b6a465a53626d0b932e15d343378 WHIRLPOOL 944056998ed0938f23d5235ab433dc56b6764c54e28c2d16cf8823c58cf61b42d156765e9253e4260bd5719231c922e9815c18e097b58391626f7163d8b92d71

View File

@ -0,0 +1,11 @@
diff -u /var/tmp/portage/media-sound/rubyripper-0.6.2/work/rubyripper-0.6.2-orig/configure /var/tmp/portage/media-sound/rubyripper-0.6.2/work/rubyripper-0.6.2/configure
--- /var/tmp/portage/media-sound/rubyripper-0.6.2/work/rubyripper-0.6.2-orig/configure 2011-12-14 23:06:03.000000000 +0400
+++ /var/tmp/portage/media-sound/rubyripper-0.6.2/work/rubyripper-0.6.2/configure 2017-02-04 12:49:46.109897466 +0300
@@ -1,4 +1,6 @@
#!/usr/bin/env ruby
+Encoding.default_external = Encoding::UTF_8
+Encoding.default_internal = Encoding::UTF_8
# Rubyripper - A secure ripper for Linux/BSD/OSX
# Copyright (C) 2007 Bouke Woudstra (rubyripperdev@gmail.com)
#
Common subdirectories: /var/tmp/portage/media-sound/rubyripper-0.6.2/work/rubyripper-0.6.2-orig/locale and /var/tmp/portage/media-sound/rubyripper-0.6.2/work/rubyripper-0.6.2/locale

View File

@ -0,0 +1,14 @@
--- rubyripper/rr_lib.rb 2010-10-16 18:02:03.700000029 +0800
+++ rubyripper/rr_lib.rb 2010-10-16 22:27:46.060000028 +0800
@@ -2331,8 +2331,8 @@
command = String.new
command.force_encoding("UTF-8") if command.respond_to?("force_encoding")
- command +="flac #{@settings['flacsettings']} -o \"#{filename}\" #{tags}\
-\"#{@out.getTempFile(track, 1)}\""
+ command +="flac #{@settings['flacsettings'].force_encoding("UTF-8")} -o \"#{filename.force_encoding("UTF-8")}\" #{tags.force_encoding("UTF-8")}\
+\"#{@out.getTempFile(track, 1).force_encoding("UTF-8")}\""
command += " 2>&1" unless @settings['verbose']
checkCommand(command, track, 'flac')

View File

@ -0,0 +1,44 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby21 ruby22 ruby23"
inherit eutils
DESCRIPTION="Rubyripper aims to deliver high quality rips from audio cd's to your computer drive. It tries to do so by ripping the same track with cdparanoia multiple times and then comparing the results."
HOMEPAGE="https://github.com/bleskodev/rubyripper"
SRC_URI="https://github.com/bleskodev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="gtk2 +cli +flac vorbis mp3 aac"
REQUIRED_USE="|| ( cli gtk2 )"
DEPEND="media-sound/cdparanoia
>=dev-lang/ruby-1.9
media-sound/cd-discid
flac? ( media-libs/flac )
mp3? ( media-sound/lame )
vorbis? ( media-sound/vorbis-tools )
aac? ( media-sound/neroaac )
gtk2? ( dev-ruby/ruby-gtk2 )
media-sound/sox
media-sound/normalize
app-cdr/cdrdao
dev-ruby/ruby-gettext
"
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/0.6.2-utf8-fix.patch
}
src_configure() {
econf \
--enable-lang-all \
$(use_enable gtk2) \
$(use_enable cli)
}

View File

@ -0,0 +1,2 @@
DIST whipper-0.4.2.tar.gz 179705 SHA256 a40b0a07b6e8edcd387848582af904e607bff936690df0ee57548cc16474baf4 SHA512 04bab47dff73ac5c1476deda16d011bb68de1c945cb30b2e4673a5097afd5cf928a1cdfaaa6082bf51695f0e10a6257d313aa8f1b51b4b6a758bd47358ec023d WHIRLPOOL ae0756e97ba9a7fac396ada2ecf10eb98adf37377918905a923545261e85d6c0973adcf2f81f29f67c2297e799a49b1e6aa0d718454608e629bbbd00d44c02fe
EBUILD whipper-0.4.2.ebuild 1250 SHA256 c50b10dc1f2112ebba7a0198c9e4e6ee6ccd684402baaa6b75165b30abdf707c SHA512 e89b643a81422b6ac91e281511d8996677c0abb22c1721c0222b265943d501e876146d2a58e6faf133df476cc5255ff750a5df13aace4d0220787538a41653a2 WHIRLPOOL d2fe98de8d5e8d376ec88035cb91d345fda212d5c4d1528b197397ff9f7690aa9f5946ddf715004fc9ad954f4b213db9b54284967d991b998c980f38d94454fb

View File

@ -0,0 +1,49 @@
# Copyright 1999-2014 Tiziano Mueller
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI="5"
PYTHON_COMPAT=( python2_7 )
inherit bash-completion-r1 distutils-r1
DESCRIPTION="CD-DA ripper, fork of the morituri project (CDDA ripper for *nix systems aiming for accuracy over speed)"
HOMEPAGE="https://github.com/JoeLametta/whipper"
SRC_URI="https://github.com/JoeLametta/whipper/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="alac +cddb +cdio +flac test wav wavpack"
RDEPEND="${PYTHON_DEPS}
!media-sound/morituri
media-sound/cdparanoia
app-cdr/cdrdao
media-libs/gstreamer:0.10
media-sound/sox
dev-python/python-musicbrainz-ngs
alac? ( media-plugins/gst-plugins-ffmpeg )
cddb? ( dev-python/cddb-py[${PYTHON_USEDEP}] )
cdio? ( dev-python/pycdio )
flac? ( media-plugins/gst-plugins-flac media-libs/flac )
wav? ( media-libs/gst-plugins-good media-libs/libsndfile )
wavpack? ( media-plugins/gst-plugins-wavpack )
dev-python/gst-python:0.10[${PYTHON_USEDEP}]
"
python_test() {
esetup.py test
}
src_compile() {
cd "${S}/src"
emake
}
python_install_all() {
distutils-r1_python_install_all
dobin "${S}/src/accuraterip-checksum"
}