app-office/jal: add db file path patch
This commit is contained in:
parent
6219b6e558
commit
33cbf1043e
|
@ -1,2 +1,3 @@
|
||||||
|
AUX jal-dbfilepath.patch 779 BLAKE2B 57be678fc71555953f9585ba1de523e0d4c91115ce870837933ba7f8794456e4733b9228b55cbd686120338eabfc87cca7840f9434f198690df87be7bcea186b SHA512 62f51e70877a800c4dea9ad831973b9106424bb18ff4fc09547a1a305085d4eb36b7c9e335e74204953c5a604799404efeef588bae568e4c14b2d43d458fbcd6
|
||||||
DIST jal-2024.7.1.tar.gz 3513811 BLAKE2B 9a5d18c88efc90da661a45720b60a18e716a381c8e848f500f2a6beabbe27276cc12b8cae8f165edd5ca0768b0f9c34331385d1c0fc5b3c0b3aa978e95f8589c SHA512 7975af5878213aa3caf581107465b08da5f2ecaf9c1b0f74be2184bfd26ced03073f3f064f6ff23a869e2821f20d7a60446c1640c82e7e1b1d49401027b3ce71
|
DIST jal-2024.7.1.tar.gz 3513811 BLAKE2B 9a5d18c88efc90da661a45720b60a18e716a381c8e848f500f2a6beabbe27276cc12b8cae8f165edd5ca0768b0f9c34331385d1c0fc5b3c0b3aa978e95f8589c SHA512 7975af5878213aa3caf581107465b08da5f2ecaf9c1b0f74be2184bfd26ced03073f3f064f6ff23a869e2821f20d7a60446c1640c82e7e1b1d49401027b3ce71
|
||||||
EBUILD jal-2024.7.1.ebuild 1121 BLAKE2B 5e8f37a5afbddcf92a929d2149cce61d76e8303fc0fbc1f79a9b0926025e45f1e0da80e97b0eb8d90d0952b6b7eb801772293e6dbefab051c133e5f36620d043 SHA512 0a8758014f76117315fab5c4107185e996a2b7a87f2a11e0c6090db54fc6cf08cd4de8382f7e59ab78319e4d27024340f3c670f2e8265e88911479179a66acd4
|
EBUILD jal-2024.7.1.ebuild 1186 BLAKE2B 60392f0a7b1f3c1041fd0b284daa40232dac721248cded19a1ca01084d0c106a40e85b0b7fcf510c80499fc5017ab3a19d259b6c37b868048e00d28acaf23bc3 SHA512 306448471b82a8231711ee22023ae413d19ada4578a7976d3c2ac90172f7c4efeaab9f3332e0c79dea21fcdb274a77109237e1d941bde38b19fd6958b333601d
|
||||||
|
|
|
@ -0,0 +1,14 @@
|
||||||
|
diff -ur jal-2024.7.1.orig/jal/db/db.py jal-2024.7.1.new/jal/db/db.py
|
||||||
|
--- jal-2024.7.1.orig/jal/db/db.py 2024-08-01 00:26:42.000000000 +0300
|
||||||
|
+++ jal-2024.7.1.new/jal/db/db.py 2024-08-18 09:26:30.292027271 +0300
|
||||||
|
@@ -104,7 +104,9 @@
|
||||||
|
if "pytest" in sys.modules:
|
||||||
|
return os.environ['JAL_TEST_PATH'] + os.sep + Setup.DB_PATH # Use custom path if in test environment
|
||||||
|
else:
|
||||||
|
- return JalDB.get_app_path() + Setup.DB_PATH
|
||||||
|
+ DBfilepath = os.path.expanduser('~') + '/.jal/' + Setup.DB_PATH
|
||||||
|
+ os.makedirs(os.path.dirname(DBfilepath), exist_ok=True)
|
||||||
|
+ return DBfilepath
|
||||||
|
|
||||||
|
# -------------------------------------------------------------------------------------------------------------------
|
||||||
|
# This function:
|
|
@ -19,7 +19,7 @@ KEYWORDS="~amd64"
|
||||||
DEPEND=">=dev-lang/python-3.8.1
|
DEPEND=">=dev-lang/python-3.8.1
|
||||||
>=dev-python/lxml-4.5.0[${PYTHON_USEDEP}]
|
>=dev-python/lxml-4.5.0[${PYTHON_USEDEP}]
|
||||||
>=dev-python/pandas-1.1.1[${PYTHON_USEDEP}]
|
>=dev-python/pandas-1.1.1[${PYTHON_USEDEP}]
|
||||||
>=dev-python/pyside6-6.5.1[${PYTHON_USEDEP},positioning,webengine]
|
>=dev-python/pyside6-6.5.1[${PYTHON_USEDEP},positioning,webengine,charts]
|
||||||
>=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
|
>=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
|
||||||
>=dev-python/xlsxwriter-1.3.3[${PYTHON_USEDEP}]
|
>=dev-python/xlsxwriter-1.3.3[${PYTHON_USEDEP}]
|
||||||
dev-python/jsonschema[${PYTHON_USEDEP}]
|
dev-python/jsonschema[${PYTHON_USEDEP}]
|
||||||
|
@ -30,6 +30,10 @@ RDEPEND="${DEPEND}"
|
||||||
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
|
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
|
||||||
dev-python/pytest[${PYTHON_USEDEP}]"
|
dev-python/pytest[${PYTHON_USEDEP}]"
|
||||||
|
|
||||||
|
PATCHES=(
|
||||||
|
"${FILESDIR}/${PN}-dbfilepath.patch"
|
||||||
|
)
|
||||||
|
|
||||||
python_prepare_all() {
|
python_prepare_all() {
|
||||||
distutils-r1_python_prepare_all
|
distutils-r1_python_prepare_all
|
||||||
|
|
||||||
|
|
Loading…
Reference in New Issue