net-misc/netplan: bump version 0.105

master
Alexander Miroshnichenko 2022-09-28 14:40:28 +03:00
parent fd75847f2b
commit 39f089a685
Signed by: alex
GPG Key ID: E93720C6C73A77F4
4 changed files with 62 additions and 53 deletions

View File

@ -1,2 +1,3 @@
DIST netplan-0.104.tar.gz 266313 BLAKE2B 46ea64ed646148945e2c1b36df9fdf0c58ffa1add55d32e0ee4888a50f47c2dc7cc78c8d152c92e418c5a988203576af15142a22d93342a52717b7a0d59e77b8 SHA512 3581f391f695d8e9daf6281c35bd701bfcf326fa6d2405c935270e7a32583224612649ef46d9698abd5dc4b7f1359d7c9982589de273d3cc4ed67ca1da7a7db7
EBUILD netplan-0.104.ebuild 1302 BLAKE2B 35fffa12d27d85baf885cb3ccf9ad602ec37c23d59b878f0cf8dcefe14741fa90c3080ef555c414ae5dc6cbebe3364a554cf019a116997ddf4767d2368fa6c09 SHA512 84ca1c60960d1793aa23bdaeb50237d7849f7ada704fab79cd475c89e1346d44a92fd0b095467351d16c0a5a57b7ba9b95a8389bb910418c23b30128a43a7920
AUX netplan-deps.patch 925 BLAKE2B 618abad9835920c22d77c8c909f762521a28566d421b378df473b2f2255a77a23647b95e89f7c82e954d4c337ad84ae97672f2dd313c8b4ef7a7e5f416af76c3 SHA512 fca0a7b062a2a4f89d3c103253dd9b1f4c71b1a7c8caa6b3c49ac2f2b2fe76d648ac512793467f6bd79aa6d1eb31c3d61c2d9ef77b617545e19650267c9dce6f
DIST netplan-0.105.tar.gz 329150 BLAKE2B 6c4e5034239aeff0ff733e7a05ec5676e4250d89f4cb57630f51b135c1fe9647d5b3b5d873c82fc926ef6256af86fe3ba5fec3d13643d809bdeb9b2c36d1f59a SHA512 9dde73a3cf2cb25b8ca26fa73104f0109d96162d1e094137e4e6d005998aa3d9c61df2f810b416a979aed4c7f110ef79ccc0de976d4588b144d2752a9ef0ebcb
EBUILD netplan-0.105.ebuild 894 BLAKE2B 52db903d4dd01b205fba8c31a120e05f22cfb60a9b639b5378bdccf67cf001f1dadf2392ce74a5c7ae64fe962b92e18a8d62bc03fdf8e8f0e6924524aca94557 SHA512 18498cbafaabf76d83b5e90f16b482e168b775e73db3046750d9fccb801a2d28be1ab7ade3197814f2dc9c2c1b82c319001515f312f9a667d0643d7131540f86

View File

@ -0,0 +1,18 @@
diff --git a/meson.build b/meson.build
index 7f48cb4f244a..bebff535460a 100644
--- a/meson.build
+++ b/meson.build
@@ -20,10 +20,10 @@ completions = dependency('bash-completion')
systemd_generator_dir = systemd.get_variable(pkgconfig: 'systemdsystemgeneratordir')
bash_completions_dir = completions.get_variable(pkgconfig: 'completionsdir', default_value: '/etc/bash_completion.d')
-# Order: Fedora/Mageia/openSUSE || Debian/Ubuntu
-pyflakes = find_program('pyflakes-3', 'pyflakes3', required: false)
+# Order: Fedora/Mageia/openSUSE || Debian/Ubuntu || Gentoo
+pyflakes = find_program('pyflakes-3', 'pyflakes3', 'pyflakes', required: false)
pycodestyle = find_program('pycodestyle-3', 'pycodestyle', 'pep8', required: false)
-nose = find_program('nosetests-3', 'nosetests3')
+nose = find_program('nosetests-3', 'nosetests3', 'nosetests')
pandoc = find_program('pandoc', required: false)
find = find_program('find')

View File

@ -1,51 +0,0 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="Backend-agnostic network configuration in YAML"
HOMEPAGE="https://netplan.io/"
SRC_URI="https://github.com/CanonicalLtd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc systemd"
REQUIRED_USE="systemd"
DEPEND="
>=dev-libs/glib-2.64.3
>=dev-libs/libyaml-0.2.5
doc? ( >=app-text/pandoc-1.19.2.1-r1 )"
RDEPEND="
>=dev-python/netifaces-0.10.9
>=dev-libs/libyaml-0.2.5
>=dev-python/pyyaml-5.3.1[libyaml(+)]"
src_prepare() {
sed -i -e "s:\$(DOCDIR)/netplan:\$(DOCDIR)/${PF}:" Makefile || die
if ! use doc; then
sed -i -e 's@doc/netplan.html.*@@g' Makefile || die
sed -i -e '/m 644 doc\/*./Id' Makefile || die
fi
# baselayout-1 compat
if has_version ">=sys-apps/baselayout-2.0.0"; then
sed -i -e 's:sbin/wpa_supplicant:usr/sbin/wpa_supplicant:' src/networkd.c || die
fi
eapply_user
}
src_install() {
if [[ -f Makefile ]] || [[ -f GNUmakefile ]] || [[ -f makefile ]] ; then
emake DESTDIR="${D}" LIBDIR="\${PREFIX}/$(get_libdir)" install
fi
einstalldocs
}

View File

@ -0,0 +1,41 @@
# Copyright 1999-2022 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit meson systemd
DESCRIPTION="Backend-agnostic network configuration in YAML"
HOMEPAGE="https://netplan.io/"
SRC_URI="https://github.com/CanonicalLtd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc systemd bash-completion"
REQUIRED_USE="systemd bash-completion"
DEPEND=">=dev-libs/glib-2.64.3
>=dev-libs/libyaml-0.2.5
sys-apps/systemd
sys-apps/util-linux
app-shells/bash-completion
doc? ( >=app-text/pandoc-1.19.2.1-r1 )
"
BDEPEND="${DEPEND}
dev-python/nose
dev-python/pycodestyle
dev-python/pyflakes
"
RDEPEND=">=dev-python/netifaces-0.10.9
>=dev-libs/libyaml-0.2.5
>=dev-python/pyyaml-5.3.1[libyaml(+)]
"
PATCHES=(
"${FILESDIR}/netplan-deps.patch"
)