net-misc/netplan: add musl libc compat patch
This commit is contained in:
parent
4abbfa541c
commit
acd9ae18ed
|
@ -1,3 +1,4 @@
|
|||
AUX 0001-build-add-Gentoo-compat.patch 1739 BLAKE2B 6090333af0b87774252869d83d0ab9a4f2a65f1428035ded0680281903715db20df8b76852b38c680d23bab30933fcae195fb8597cd019a4d6f5efb394f3afb1 SHA512 97bc8ea068ebae6b92adc78a3709fd3648366d67b098d1dcbac9fb3ead12781f0cee96d9032654e6818faafc320b4949161e6b40b7288db11f725ade275950e6
|
||||
AUX 0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch 626 BLAKE2B d361ab1cb082ff7468aeb1242ebdaaddfbf7f47c54898a9cadc2c833f74662cbbd5ff4fe4ea06ab9e943af0f1ab2f82651b4f0df5490f24a89c1ef0e2f642555 SHA512 f3d32fc9d09776a72b278c51dbeb3fdbf3dd721ce6b69c1471c15243aae39d000ace5ffe2d6bbfa95fb2d3b0efbbeaf3de9b2f234b15099221e0d64ba3e89cbc
|
||||
DIST netplan-1.1.1.tar.gz 516669 BLAKE2B 6cbb9f39f2e62b592cee7b26889811db0bf5ba69ab0d30603306d78574e4f469a6860d52509ba9f679f724abe29e015e5b003ca7a9d40fe461e45b888917d858 SHA512 97e749d33989b4650b51fd8ca48bb6328a0c6a759055868a0c682af20f928643e1261f6e87bdaf679278f9f2c689a729bceeab8cad51f4c10a7bf26910a5d406
|
||||
EBUILD netplan-1.1.1.ebuild 1722 BLAKE2B f40a73db2a1285327739a956643de45ab8a471833cbd8e4061131ae99c5fad2ee7862ff1708a7b7f3022ad6ff3e70a581df481f999ee21e02c4210ef0ac0c371 SHA512 ce48f9d8395026af00d44fbbeb1db8cc2dc23702ddddc62f1263020b3e5dcc936c283837fe08943449c80524ae658a8a3e64a0904e95178dd612491c29ffa84d
|
||||
EBUILD netplan-1.1.1.ebuild 1977 BLAKE2B e7238b2d33b79a7b70a4bbe88a7daee2be7926094538a094a17a0fa70ecd7527c9faedcf57ba4b348106719fdc6e58db50faedce0eb816607640077eee1886de SHA512 0e1113de4e4fbeee3ed3432a77ea50e84d76e74a4ae93a51b11a41356498ff95a8d370f948fa0204c0eb61c151ffae53969af824f175ad9ada93ceeedb871c42
|
||||
|
|
|
@ -0,0 +1,28 @@
|
|||
From 9c8e47d9721a390b877fc7de82bef1e9a1857714 Mon Sep 17 00:00:00 2001
|
||||
From: Alexander Miroshnichenko <alex@millerson.name>
|
||||
Date: Fri, 25 Oct 2024 08:18:59 +0300
|
||||
Subject: [PATCH] don't fail if GLOB_BRACE is not defined
|
||||
|
||||
---
|
||||
src/util.c | 6 ++++++
|
||||
1 file changed, 6 insertions(+)
|
||||
|
||||
diff --git a/src/util.c b/src/util.c
|
||||
index 294a2f4..44f62c6 100644
|
||||
--- a/src/util.c
|
||||
+++ b/src/util.c
|
||||
@@ -39,6 +39,12 @@
|
||||
#include "names.h"
|
||||
#include "yaml-helpers.h"
|
||||
|
||||
+/* Don't fail if the standard library
|
||||
+ * doesn't provide brace expansion */
|
||||
+#ifndef GLOB_BRACE
|
||||
+#define GLOB_BRACE 0
|
||||
+#endif
|
||||
+
|
||||
GHashTable*
|
||||
wifi_frequency_24;
|
||||
|
||||
--
|
||||
2.45.2
|
|
@ -18,7 +18,7 @@ SLOT="0"
|
|||
|
||||
KEYWORDS="~amd64"
|
||||
|
||||
IUSE="examples +systemd +bash-completion test lto"
|
||||
IUSE="elibc_musl +examples +systemd +bash-completion test lto"
|
||||
REQUIRED_USE="systemd bash-completion"
|
||||
|
||||
DEPEND=">=dev-libs/glib-2.64.3
|
||||
|
@ -44,12 +44,22 @@ RDEPEND=">=dev-python/netifaces-0.10.9
|
|||
app-shells/bash-completion
|
||||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/0001-build-add-Gentoo-compat.patch"
|
||||
)
|
||||
|
||||
distutils_enable_sphinx doc
|
||||
|
||||
src_prepare() {
|
||||
local PATCHES=(
|
||||
"${FILESDIR}/0001-build-add-Gentoo-compat.patch"
|
||||
)
|
||||
|
||||
if use elibc_musl; then
|
||||
PATCHES+=(
|
||||
"${FILESDIR}/0001-don-t-fail-if-GLOB_BRACE-is-not-defined.patch"
|
||||
)
|
||||
fi
|
||||
|
||||
default
|
||||
}
|
||||
|
||||
python_configure() {
|
||||
local emesonargs=(
|
||||
$(meson_use test unit_testing)
|
||||
|
|
Loading…
Reference in New Issue