add media-sound/sacd-extract package; bump net-misc/netplan version 0.106; bump sys-kernel/hardened-kernel version 6.1.13
This commit is contained in:
parent
438d57b433
commit
d329d62aae
|
@ -0,0 +1,2 @@
|
|||
DIST sacd-ripper-0.3.9.3.tar.gz 4719544 BLAKE2B 889a57225471b85e37c4f0baf6f9cece7aebc2464485488e440033ebcccf559472ac9f35106569499513f60cf02dab58dd82ac956324c08d70614bbc6ccb8159 SHA512 60b051950eb4aa8ad2acba99212741c50be6e7634de22482f1c0f47943a49cd37a041fc38a62d87a78f6dffa0bb1b6a0aec6af6a1b497082b28b4560fbb32b45
|
||||
EBUILD sacd-extract-0.3.9.3.ebuild 766 BLAKE2B 7f18571fd0a6c950b0b7ac936e733e3b05a7a8301554a896fce048a5f0e5695f8b2afef6933baf2028106414b9fb15aa7630d0b00c0fbe3e7d4e69d9af761ed4 SHA512 3058e70bd7570d7fe4e5027bc672f9379fd4bac5001cc683a527416030f1ccd8f0dabe80dee2082d97de79f9fe6340e5050086ea9764950b9f89dfe6399c6158
|
|
@ -0,0 +1,33 @@
|
|||
# Copyright 2023 Gentoo Authors
|
||||
# Distributed under the terms of the GNU General Public License v2
|
||||
|
||||
EAPI=8
|
||||
|
||||
PN=sacd-ripper
|
||||
P=${PN}-${PV}
|
||||
|
||||
inherit cmake
|
||||
|
||||
DESCRIPTION="SACD ripping software using a PS3"
|
||||
HOMEPAGE="https://github.com/sacd-ripper/sacd-ripper"
|
||||
|
||||
if [[ ${PV} == *9999 ]] ; then
|
||||
EGIT_REPO_URI="https://github.com/sacd-ripper/${PN}.git"
|
||||
inherit git-r3
|
||||
else
|
||||
SRC_URI="https://github.com/sacd-ripper/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
|
||||
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
|
||||
fi
|
||||
|
||||
LICENSE="GPL-2.0"
|
||||
SLOT="0"
|
||||
|
||||
DEPEND="dev-libs/libxml2"
|
||||
RDEPEND="${DEPEND}"
|
||||
BDEPEND=""
|
||||
|
||||
S="${WORKDIR}/${P}/tools/sacd_extract"
|
||||
|
||||
src_install(){
|
||||
dobin "${S}"_build/sacd_extract
|
||||
}
|
|
@ -1,4 +1,3 @@
|
|||
AUX 0001-buildsystem-meson-fixes.patch 4669 BLAKE2B bda3c0fbc3fde706dba7d39dd9e3fa00a86ea98fc03a65d03870a364ac4d9b326089939559a5db37b16c427b9cb07d715ee6577d33330a2583ac6e23de2ff90f SHA512 87d6c01b2e733946416fed8e464d196ed9865a4b2919b54e854bbd55628a6a5343beb23f8bde31b64e2bb4b1ac9db108890cbf292821ad64ec839dbf4221d903
|
||||
AUX netplan-deps.patch 925 BLAKE2B 618abad9835920c22d77c8c909f762521a28566d421b378df473b2f2255a77a23647b95e89f7c82e954d4c337ad84ae97672f2dd313c8b4ef7a7e5f416af76c3 SHA512 fca0a7b062a2a4f89d3c103253dd9b1f4c71b1a7c8caa6b3c49ac2f2b2fe76d648ac512793467f6bd79aa6d1eb31c3d61c2d9ef77b617545e19650267c9dce6f
|
||||
DIST netplan-0.105.tar.gz 329150 BLAKE2B 6c4e5034239aeff0ff733e7a05ec5676e4250d89f4cb57630f51b135c1fe9647d5b3b5d873c82fc926ef6256af86fe3ba5fec3d13643d809bdeb9b2c36d1f59a SHA512 9dde73a3cf2cb25b8ca26fa73104f0109d96162d1e094137e4e6d005998aa3d9c61df2f810b416a979aed4c7f110ef79ccc0de976d4588b144d2752a9ef0ebcb
|
||||
EBUILD netplan-0.105-r1.ebuild 971 BLAKE2B 7497a310024f568efb3440f8204e62c7b58e1db01a1fa0955ebd85fff7371d3fc8d548ea5044d5c9d2f69d7a62c99058add2f5df3a3bea4b4e2e04a0bbc9163d SHA512 1d7e0a4da24adf8e5ce584ccca4c066e3d5cc8dbb4fa028c470eaca6ecb770fd3215ed0735e5a50154106c983399c6658b0e9c9b9b1289c710757b8b3358edd5
|
||||
DIST netplan-0.106.tar.gz 364280 BLAKE2B 7752470df1751faf36349a401bcdc30aa0a5cf27d08bc48a0953dcd950cd3f8386b5c3487bd9a3aeeeb74eca40f7fdb4fc7cb675bb89c9ae67d965d339f21921 SHA512 9f3c28770d5071d3df3664a885b37a0712c8f28240bc354d0b4f1d21afdb280791ceddfc323089287d57143d46a13748e7c09d7ecc098601a988b7a98f11c84f
|
||||
EBUILD netplan-0.106.ebuild 916 BLAKE2B f5494a5792bbcd8b3030c70d634c1c5a12acb940c575b64917cd6f3d7deedfbd5031d5d3d07980e60ed525b2980cf70ddc96c64d58437969314c0c998d3f2edd SHA512 7626c84ebf1de032e60448e9698c20e9cdcb64f6ce41d9404530873f77302d169f4ede99c172207514c2b2d5aa1054982b8071a8aaf6ddde2e5476ba31c7acf5
|
||||
|
|
|
@ -1,139 +0,0 @@
|
|||
From 89948ed72b80c2671981ce6bb995dccbb5e389b6 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Lukas=20M=C3=A4rdian?= <slyon@ubuntu.com>
|
||||
Date: Wed, 24 Aug 2022 12:34:51 +0200
|
||||
Subject: [PATCH] buildsystem: meson fixes
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
- install all files
|
||||
- POSIX shell compatibility in generators
|
||||
- use custom_targets for generators
|
||||
- fix dbus install directory
|
||||
|
||||
Signed-off-by: Alexander Miroshnichenko <alex@millerson.name>
|
||||
---
|
||||
dbus/meson.build | 12 +++++++++++-
|
||||
features_h_generator.sh | 6 ++++--
|
||||
features_py_generator.sh | 6 ++++--
|
||||
meson.build | 5 -----
|
||||
netplan/meson.build | 15 +++++++++++++--
|
||||
5 files changed, 32 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/dbus/meson.build b/dbus/meson.build
|
||||
index 68a6ce39208d..fc34e2c2cbf7 100644
|
||||
--- a/dbus/meson.build
|
||||
+++ b/dbus/meson.build
|
||||
@@ -1,6 +1,16 @@
|
||||
+features_h = custom_target(
|
||||
+ build_always_stale: true,
|
||||
+ output: '_features.h',
|
||||
+ input: join_paths(meson.project_source_root(), 'features_h_generator.sh'),
|
||||
+ command: ['sh', '-c', '@INPUT@'],
|
||||
+ install: false,
|
||||
+ capture: true,
|
||||
+)
|
||||
+
|
||||
executable(
|
||||
'netplan-dbus',
|
||||
'../src/dbus.c',
|
||||
+ features_h,
|
||||
include_directories: inc,
|
||||
link_with: libnetplan,
|
||||
dependencies: [libsystemd, glib, gio, yaml, uuid],
|
||||
@@ -9,7 +19,7 @@ executable(
|
||||
|
||||
install_data(
|
||||
'io.netplan.Netplan.conf',
|
||||
- install_dir: join_paths(get_option('datadir'), 'dbus-1', 'systemd.d'))
|
||||
+ install_dir: join_paths(get_option('datadir'), 'dbus-1', 'system.d'))
|
||||
|
||||
conf_data = configuration_data()
|
||||
conf_data.set('ROOTLIBEXECDIR', join_paths(get_option('prefix'), get_option('libexecdir')))
|
||||
diff --git a/features_h_generator.sh b/features_h_generator.sh
|
||||
index ed9c3cc78cab..d38771515a2d 100755
|
||||
--- a/features_h_generator.sh
|
||||
+++ b/features_h_generator.sh
|
||||
@@ -1,6 +1,8 @@
|
||||
#!/bin/sh
|
||||
-OUTPUT=src/_features.h
|
||||
-INPUT=src/[^_]*.[hc]
|
||||
+BASE=$(dirname $0)
|
||||
+OUTPUT=$BASE/src/_features.h
|
||||
+INPUT=$BASE/src/[!_]*.[hc]
|
||||
printf "#include <stddef.h>\nstatic const char *feature_flags[] __attribute__((__unused__)) = {\n" > $OUTPUT
|
||||
awk 'match ($0, /netplan-feature:.*/ ) { $0=substr($0, RSTART, RLENGTH); print "\""$2"\"," }' $INPUT >> $OUTPUT
|
||||
echo "NULL, };" >> $OUTPUT
|
||||
+cat $OUTPUT
|
||||
diff --git a/features_py_generator.sh b/features_py_generator.sh
|
||||
index ecb42af47e75..bbbe3a4e3e30 100755
|
||||
--- a/features_py_generator.sh
|
||||
+++ b/features_py_generator.sh
|
||||
@@ -1,7 +1,9 @@
|
||||
#!/bin/sh
|
||||
-OUTPUT=netplan/_features.py
|
||||
-INPUT=src/[^_]*.[hc]
|
||||
+BASE=$(dirname $0)
|
||||
+OUTPUT=$BASE/netplan/_features.py
|
||||
+INPUT=$BASE/src/[!_]*.[hc]
|
||||
echo "# Generated file" > $OUTPUT
|
||||
echo "NETPLAN_FEATURE_FLAGS = [" >> $OUTPUT
|
||||
awk 'match ($0, /netplan-feature:.*/ ) { $0=substr($0, RSTART, RLENGTH); print " \""$2"\"," }' $INPUT >> $OUTPUT
|
||||
echo "]" >> $OUTPUT
|
||||
+cat $OUTPUT
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 3ab07765b38e..7f48cb4f244a 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -32,11 +32,6 @@ add_project_arguments(
|
||||
'-D_XOPEN_SOURCE=700',
|
||||
language: 'c')
|
||||
|
||||
-message('Generating the _features.[py|h] code')
|
||||
-#XXX: this is ugly as it produces artifacts in the source directory
|
||||
-run_command('features_h_generator.sh', check: true)
|
||||
-run_command('features_py_generator.sh', check: true)
|
||||
-
|
||||
inc = include_directories('include')
|
||||
subdir('include')
|
||||
subdir('src')
|
||||
diff --git a/netplan/meson.build b/netplan/meson.build
|
||||
index 1313cb40ebad..07a13e2cc484 100644
|
||||
--- a/netplan/meson.build
|
||||
+++ b/netplan/meson.build
|
||||
@@ -4,10 +4,21 @@ install_symlink(
|
||||
pointing_to: '../share/netplan/netplan.script',
|
||||
install_dir: get_option('sbindir'))
|
||||
|
||||
+netplan_module = join_paths(get_option('datadir'), meson.project_name(), 'netplan')
|
||||
+features_py = custom_target(
|
||||
+ build_always_stale: true,
|
||||
+ output: '_features.py',
|
||||
+ input: join_paths(meson.project_source_root(), 'features_py_generator.sh'),
|
||||
+ command: ['sh', '-c', '@INPUT@'],
|
||||
+ install: true,
|
||||
+ install_dir: netplan_module,
|
||||
+ capture: true,
|
||||
+)
|
||||
+
|
||||
netplan_sources = files(
|
||||
'__init__.py',
|
||||
- '_features.py',
|
||||
'configmanager.py',
|
||||
+ 'libnetplan.py',
|
||||
'terminal.py')
|
||||
|
||||
cli_sources = files(
|
||||
@@ -26,9 +37,9 @@ commands_sources = files(
|
||||
'cli/commands/ip.py',
|
||||
'cli/commands/migrate.py',
|
||||
'cli/commands/set.py',
|
||||
+ 'cli/commands/sriov_rebind.py',
|
||||
'cli/commands/try_command.py')
|
||||
|
||||
-netplan_module = join_paths(get_option('datadir'), meson.project_name(), 'netplan')
|
||||
install_data(netplan_sources, install_dir: netplan_module)
|
||||
install_data(cli_sources, install_dir: join_paths(netplan_module, 'cli'))
|
||||
install_data(commands_sources, install_dir: join_paths(netplan_module, 'cli', 'commands'))
|
||||
--
|
||||
2.26.2
|
||||
|
|
@ -26,7 +26,7 @@ DEPEND=">=dev-libs/glib-2.64.3
|
|||
"
|
||||
|
||||
BDEPEND="${DEPEND}
|
||||
dev-python/nose
|
||||
dev-python/pytest
|
||||
dev-python/pycodestyle
|
||||
dev-python/pyflakes
|
||||
"
|
||||
|
@ -37,6 +37,5 @@ RDEPEND=">=dev-python/netifaces-0.10.9
|
|||
"
|
||||
|
||||
PATCHES=(
|
||||
"${FILESDIR}/0001-buildsystem-meson-fixes.patch"
|
||||
"${FILESDIR}/netplan-deps.patch"
|
||||
)
|
|
@ -1,7 +1,8 @@
|
|||
AUX linux-6.1.amd64.config 174994 BLAKE2B 927affead8ede8b9d47ab8887660a5ab87629c826555d69b899f093ad73e1ea71938eee6b261e9921a4399f856bae0b114f6e86a6f832d692e9b3ff43e5e0842 SHA512 7503c40326c60076df92e29af7b4fbad3e2574021c63217bcb4f580c8217addb37e03b2e8c25ad3f9d57fcbe1666046b246fd66a42981f24f510710958a04bb9
|
||||
DIST genpatches-6.1-12.base.tar.xz 678732 BLAKE2B acc67136abb35e0d9985bb55002467e9d29797bcd560306511a58093ef56f86251531e54ff615dc3fee71f99633dfc372ad7bbe5a1ec2ff03d9fc23be5de04a8 SHA512 83fb419934c6314dc700f5bc9eaadf1909fbbd45dbb0e86269d942ba7f18162cbacf0acaff705144c271eb29b57c3a8027af03a73485dc887f551c002033326c
|
||||
DIST genpatches-6.1-12.extras.tar.xz 3804 BLAKE2B 59da490e3869e0b9c715453837cdae6d40b67156c966166e4d6f809e115eb9f621668a46f2632bd5eed894cdacaa5e85d26a5ef0467f95fcdeb3da3f9319a1da SHA512 d62321a73145f6275753245cad5d55b06e5fac89c7c7ed613a376c21181644e88bda7d3f7ee6f54c686bb0e534f6fdba3fdef8c9bcb06f15117276253b3a7e36
|
||||
AUX linux-6.1/9001-ALSA-usb-native-DSD-support-for-FiiO-X3-2nd-gen-DAC.patch 1028 BLAKE2B 1377ee6d8b98b557535cb1fb334b5b5c844aa530d8665217a54c6f548a597fac8e1ce72dca2feabad8dae9993dad79594832f76a7b0b449add4a60148d264eaf SHA512 0c0dfce47efd58865e29cc8f796af2928e7b7f6cdb40c3ace99e4e84e8d1077caf89cd84c0533ec685fa477bb9b26959f075b3804904a1ddd5a911e63161a5be
|
||||
DIST genpatches-6.1-15.base.tar.xz 803732 BLAKE2B 5f43fb07787e9e861b54b4977acff47c13870b24cba98296538651c656e332be2bd194b91a67d68858bb7ddf116e0e97179c5c039c64b75f4392829d091ee387 SHA512 482cb110c5d218a0b0dd4dd828862d9cfb5044b5c90f75218dd7bbf266dba1a11af11ecd913029904d6de1d572d2cbb247b5bbf1c4bb5711eb9fb03b327aaa81
|
||||
DIST genpatches-6.1-15.extras.tar.xz 3808 BLAKE2B 8d7a78f6a1e8e6bbacace9cc067b1edd674611f7ba32ced894557cc48018ce708411828dcbbd71f8678f22ebf64c8913fe8c641d29bd46d7146198ebd1240f11 SHA512 0d53e3c9740cfe65b6168c624bcc99cbd16d3e196b50190be8aeeb8bf78d205dbed964e01b151a2ad03c2ad10bb4b74f84deeb4d42db4392fe52c337540e0dc6
|
||||
DIST linux-6.1.tar.xz 134728520 BLAKE2B ae60257860b2bd1bd708d183f0443afc60ebbd2b3d535c45e44c2e541bd0928530a3b62de6385dd4e4726ebbedcc0a871d4f3ffb4105b9f1f6d8ed7467f5688e SHA512 6ed2a73c2699d0810e54753715635736fc370288ad5ce95c594f2379959b0e418665cd71bc512a0273fe226fe90074d8b10d14c209080a6466498417a4fdda68
|
||||
DIST linux-hardened-6.1.10-hardened1.patch 100241 BLAKE2B 03cf665828cddc906c945b8488bc831f44e368f4eaa1c0a8d095e73a9818a53352e0e36d4954a34ab4d9bad5e4a60e0958249ac4aabe325c66616d551ebefc62 SHA512 0c8a7ad36497abc5e34cb663c58803a5dd6e22eded1c9561fcc48449fbc53066d23e8a070fae6bcf6ffc45f06ec900db7f2a02b9956fe03c513635dcbd3fffa3
|
||||
EBUILD hardened-kernel-6.1.10.ebuild 3046 BLAKE2B d0e14f97f0f43386faa7a78eb3ce3a9905ff52470dae050a47358d849f9b4f43234665a405ba7b5deef6e679526687fdb4485b8fb7656be9f46d60f9fb1e76a5 SHA512 b5b30c60c60695fa23bb3a227c684ae608e22f8abdf85b60161fe7ae3550d21f1f8eec5ba4de14b3fbeb974cfd56cd32e504bc6a5f7b8ee4afe3aac5f1f71d39
|
||||
DIST linux-hardened-6.1.13-hardened1.patch 100241 BLAKE2B 54cbca4d682c73aa0f1cf581023ea3092878c8fbde45d1e709067d7d7da064054acbdda9a6e3e63d2e9fb1424a2119603be62071db7953a74a3c9659a77edf7f SHA512 d586f9dc681c358e6556ff0f12896bc0c5bfc6fe44bb7e50cd1ff3a3654f67390cbfd028e6f091a7c3280c7a6a0db6b307792851f568c9b8d430beda57db7c02
|
||||
EBUILD hardened-kernel-6.1.13.ebuild 3046 BLAKE2B d0e14f97f0f43386faa7a78eb3ce3a9905ff52470dae050a47358d849f9b4f43234665a405ba7b5deef6e679526687fdb4485b8fb7656be9f46d60f9fb1e76a5 SHA512 b5b30c60c60695fa23bb3a227c684ae608e22f8abdf85b60161fe7ae3550d21f1f8eec5ba4de14b3fbeb974cfd56cd32e504bc6a5f7b8ee4afe3aac5f1f71d39
|
||||
MISC metadata.xml 345 BLAKE2B 4003222d76459210cbeba27d68bcef9b42f500dd3dafe53505dae42004c5224eeae395fb30d7582de614654d2fde19d118c8c31fbc35e5335c9150d93f42efc9 SHA512 994d288cd16858bad3177d383a279f0f549ddf40ef87c62683815540b331bd48d4afa4d0c6af947e409c58f8abb5e1da045bb98dc00a422ea724cdf0610d6619
|
||||
|
|
|
@ -0,0 +1,27 @@
|
|||
From 83e4008d108f70b3951908885c766f7c43d1ac6f Mon Sep 17 00:00:00 2001
|
||||
From: Alexander Miroshnichenko <alex@millerson.name>
|
||||
Date: Fri, 24 Feb 2023 17:02:57 +0300
|
||||
Subject: [PATCH] ALSA: usb: native DSD support for FiiO X3 2nd gen DAC
|
||||
Content-Type: text/plain; charset="utf-8"
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Signed-off-by: Alexander Miroshnichenko <alex@millerson.name>
|
||||
---
|
||||
sound/usb/quirks.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/sound/usb/quirks.c b/sound/usb/quirks.c
|
||||
index 3ecd1ba7fd4b..d259fb956c69 100644
|
||||
--- a/sound/usb/quirks.c
|
||||
+++ b/sound/usb/quirks.c
|
||||
@@ -1894,6 +1894,7 @@ u64 snd_usb_interface_dsd_format_quirks(struct snd_usb_audio *chip,
|
||||
case USB_ID(0x2616, 0x0106): /* PS Audio NuWave DAC */
|
||||
case USB_ID(0x2622, 0x0041): /* Audiolab M-DAC+ */
|
||||
case USB_ID(0x27f7, 0x3002): /* W4S DAC-2v2SE */
|
||||
+ case USB_ID(0x2972, 0x0007): /* FiiO X3 2nd gen DAC */
|
||||
case USB_ID(0x29a2, 0x0086): /* Mutec MC3+ USB */
|
||||
case USB_ID(0x6b42, 0x0042): /* MSB Technology */
|
||||
if (fp->altsetting == 3)
|
||||
--
|
||||
2.39.2
|
||||
|
Loading…
Reference in New Issue