36 lines
1.7 KiB
Diff
36 lines
1.7 KiB
Diff
From 88745f4ffb91b6f8f1b7a76d019faae83b8ea0a1 Mon Sep 17 00:00:00 2001
|
|
From: Alexander Miroshnichenko <alex@millerson.name>
|
|
Date: Wed, 23 Oct 2024 17:01:19 +0300
|
|
Subject: [PATCH] build: add Gentoo compat
|
|
Content-Type: text/plain; charset="utf-8"
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Signed-off-by: Alexander Miroshnichenko <alex@millerson.name>
|
|
---
|
|
meson.build | 8 ++++----
|
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 68c740f968a4..8abfdc2fccd5 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -22,11 +22,11 @@ completions = dependency('bash-completion')
|
|
systemd_generator_dir = systemd.get_variable(pkgconfig: 'systemdsystemgeneratordir')
|
|
bash_completions_dir = completions.get_variable(pkgconfig: 'completionsdir', default_value: '/etc/bash_completion.d')
|
|
|
|
-# Order: Fedora/Mageia/openSUSE || Debian/Ubuntu
|
|
-pyflakes = find_program('pyflakes-3', 'pyflakes3', required: get_option('testing'))
|
|
+# Order: Fedora/Mageia/openSUSE || Debian/Ubuntu || Gentoo
|
|
+pyflakes = find_program('pyflakes-3', 'pyflakes3', 'pyflakes', required: get_option('testing'))
|
|
pycodestyle = find_program('pycodestyle-3', 'pycodestyle', 'pep8', required: get_option('testing'))
|
|
-pytest = find_program('pytest-3', 'pytest3', required: get_option('testing')) # also requires the pytest-cov plugin
|
|
-pycoverage = find_program('coverage-3', 'python3-coverage', required: get_option('testing'))
|
|
+pytest = find_program('pytest-3', 'pytest3', 'pytest', required: get_option('testing')) # also requires the pytest-cov plugin
|
|
+pycoverage = find_program('coverage-3', 'python3-coverage', 'coverage', required: get_option('testing'))
|
|
pandoc = find_program('pandoc', required: false)
|
|
find = find_program('find')
|
|
|
|
--
|
|
2.41.0
|
|
|